Connectivity Outage

Major incident Cellular Connectivity
2025-01-16 10:03 EST · 7 hours, 50 minutes

Updates

Resolved

This issue has been resolved by our provider.

January 16, 2025 · 17:52 EST
Issue

Our cellular provider is experiencing an outage that affects a subset of QuantAQ devices. Please follow their up-to-date status here.

January 16, 2025 · 10:38 EST

← Back